If you want to install your apps to an SD card in Windows 10, makes sure it’s formatted as NTFS

I recently purchased a 200GB SanDisk microSD card on something of a whim. Amazon had them on sale for $60, and that seemed like too good a deal to pass up. The only problem was that I didn’t have a particular use for it, all of my gadgets being already filled up with sufficient storage. I decided to pop it into my Surface Pro 4 to add some storage to my rapidly depleting allotment of super fast SSD.

One of the ways I chose to make use of the newfound storage was to move all of my Windows 10 apps over to the SD card, as well as set future apps to install there, too. Windows Phone has had this capability forever and Microsoft first added the functionality to Windows 10 in build 10558. Doing so saves me roughly 10GB of space, keeping my SSD with a tiny bit of additional free space.

Windows 10 app storage settings.

Windows 10 app storage settings.

However, my plans ran into a snag as none of the apps that were installed to the SD card would update. They’d show up in the Windows Store with available updates, and they’d start the process, but then they’d time out with an error. A bit of research showed some other people experiencing the same issue, and I was stumped.

Then, I came across a reference that hit on the issue: my SD card was formatted as exFAT. In fact, if you want to use an another drive like an SD card for installing apps, then it must be formatted as NTFS. Perhaps this is common knowledge and Microsoft made this clear at some point, but I haven’t found a reference to it.

I moved my apps back to the SSD, reformatted the card, and then just to be safe ejected and remounted it. I moved all of my apps back to the SD card, and waited for the first update to arrive. Happily, apps installed to the SD card are now updating without a problem.

In any case, if you want to install apps to an SD card or another alternative drive in Windows 10, then you’ll want to make sure the drive is formatted as NTFS. Let us know in the comments if this helped you solve the same problem.

Share This
Further reading: , ,

Have you run into this issue?