PSA: Outlook for Android will require at least Android 8.0 starting May 23

Microsoft Outlook for Android is a great app to manage your email, calendar, and contacts. It has a variety of features that allow you to customize how you want to read and write emails, but if you're on an older version of Android, be prepared to either upgrade your phone to Android 8 or higher or buy a new one. That's because Outlook for Android will require at least Android 8.0.

This comes from an announcement made on Microsoft 365 Message Center. There, Microsoft says that Outlook for Android will not support Android 7.1 or below starting May 23, this year. Microsoft also indicated that Outlook for Android users that choose to retain Android 7.1 and below will no longer receive any updates once the change is in full effect.

Share This Post:

Older

The WhatsApp UWP Beta now has a nifty emoji utility

Gaming is getting better on Windows 11 with Xbox HDR Calibration app, other optimizations

Newer